Joto connects but does nothing else. No light

I’m on PC. Thanks for your help with this!

It seems like I am having the same issue that jxn had, I can connect to the Joto but no lights and the app seems to hang when sending Joto. I’m on firmware 1.3.0. I use a Mac. How do get the updates that you mentioned?

Hi @jokr - we have a Mac firmware tool available. Can you drop me an email at and we can get you up and running

It’s been more than two months since a fix for my issue was promised within “a few days.” Nothing has been delivered so far. Since my Joto is currently a brick, perhaps it would be easier for you to ship me a replacement unit? I really would like to be able to use it.

Hi @jxn - sorry, just a lot on my plate at the moment with the launch of apps and also running a business out of lockdown in the UK. Hoping to jump back on fixing the last few bits on the Windows rescue tool shortly.

Mine is also dead. Red light barely there. Power adapter green.

1 Like

@jim Any progress? I sure would like to use my Joto! Could you have it released by the end of next week?

So weird!! My otherwise dead-as-a-doorknob Joto sprang to life just long enough to draw this, then turned back into a brick!


What can I do???

@jim @jim1 Any progress? You said “in the next few days” on January 7th! I’m pretty sure I’m not unreasonable in asking that you make this a priority now that five months have gone by.

Alternatively, one of your comments suggests that if I can find a friend with a Mac, they might be able to fix it. How would that work?

1 Like

Hi @jim,
As the PC version doesn’t seem to be ready yet, please advise us about the Mac version. I’ll try to find somebody who owns a Mac so I can finally start using my Joto again.

1 Like

It’s been six months since I posted my request for help. @jim @jim1 has repeatedly said help was on the way, but nothing has been delivered, not even after I requested a copy of the Mac fix which was supposedly done in February.

This is the community forum. Anyone have any suggestions?

@jxn - sorry for the delay. We’ve been in very low power mode during the last few months in lockdown in the UK. Things are easing up here now so hoping to get the show back on the road. Will pick up you email now

Hi @chaos - can you drop me an email at and I’ll get you back up and running.

Can you drop me an email at and I’ll get you up and running.

@jim As you requested, I sent you an email with the info from the back of my Joto. Two more months have passed and I’m just as stuck as I was on January 1. You’ve said all year that a solution is available, so I’m mystified as to why you haven’t delivered it.

Still no fix. Please hurry. It can’t be that hard to do. If you can reprogram them at joto then you should be able to reprogram them over internet. Just as an update or something.

1 Like

This is getting ridiculous. Get your head out of your ass and reprogram my joto so it can work period. All this waiting for you to do your job now all ink is dried out, nibs dried, etc. The fix should be able to be completed at home and sent over internet to repair our jotos. No reason Covid would hinder productivity.

1 Like

Any news yet? Maybe just send me a new joto that works. No updates in over a year. This is not good customer service.

1 Like

Absolutely nothing. After so many promises. The website still indicates they’re selling Jotos so I wonder what’s going on.

Still hoping a solution is being worked on. No response from anyone at joto. Can somebody do a wellness check on them.