Joto won't respond, solid red light

I got my Joto out after a few months to set up 365 days of art, but I’m having some problems.

When I plug in the joto, I see the green light on the official power supply, and a solid red light on the joto.

In the Joto app (iOS, latest version) it shows that the Joto is online, but sending jots/pressing care mode/erase buttons doesn’t do anything. Device info shows Uptime “7 days 15 hours 2 minutes 12secs” which is incorrect, and firmware 1.3.0 (but the update button shows “No Update” instead of offering to upgrade the firmware.

Any suggestions would be appreciated.

Hi @alasdair - red light would suggest a network connection issue with the device. And perhaps its not updated its status on our servers for some reason.

Firmware 1.3.0 is correct for the latest version.

Could you email and we can help diagnose the issue.

1 Like

Hello all, I have a similar issue. Solid red light and unresponsive although the app says it’s ‘connected’

Have restarted the router, unplugged and repowered Joto but still no response.

Any ideas? Is there a hard reset somewhere?

@tonyv, I emailed for help. They asked me to power on the Joto, and were able to fix it remotely.

Fingers cross the same thing works for you.

1 Like

@alasdair @tonyv - just for completeness of the thread, both of you are now up and running.

Two different issues - but anyone experiencing a red light, it generally means a network connection issue. If you hold the button down for 2 secs and let go when the pen moves and makes a noise, the Joto should restart in pairing mode with the light blinking after about 10-15 secs.

If that isn’t the case please do email for further support.

1 Like

Yes, as Admin said, mine was different and more of a Firmware issue and needed a little more in-depth support which I can happily say, Joto provided a fantastic service and it’s all rectified now… I absolutely love mine and find something fun to do with it each day!

1 Like

We changed the router in our house so the fact Joto couldn’t connect and had a red light on was expected. Followed the advice from @joto above to go through set up and change wifi credentials and it all worked nicely first time for me.

1 Like