Joto doesn't update

I tapped “Update Now v1.3.0” and “Begin Update”.
Status changes to “Waiting for data”, “Update applied. rebooting”, then goes back to the “Begin Update”. the current Firmware is still 1.0.3

after this, Joto din’t work at all. It says “ONLINE” and red light is ON. If I send a drawing to Jot, the dots are going around forever.

I restarted the app, and restarted the Jot. Jot says Ready to Jot, but it still doesn’t work.

I can still tap the “Update Now” but it’s the same. What can I do?

Hi @daichi_mn - can you email me at with the JID of your device and I’ll take a look at our update logs to see if we can see what’s going on.

Red light on constantly suggests your device isn’t online or maybe it had issues with the update. Sounds like a silly question but have you tried unplugging the device and plugging back in. Should reset things

Thank you Jim for all your support. It was great that you spent time with me to fix the issue, with emails and chat. It was one of the best dedicated support I received from Kickstarter projects. I like what JOTO can do, and I now like the support from JOTO team. I will recommend JOTO to my friends. Thanks!

Hi @daichi_mn - glad we could get you back up and Jotting again :ok_hand: