App really unresponsive

Have not used my Joto for a while but i picked it up again a couple of weeks ago when 365 was released.
It seems with all the updates the communication between the app and Joto is really unresponsive. Commands to jot are auctioned 5 to 10 minutes later, if at all, most of the time it gets stuck in a loop of saying downloading jot and only a restart of the Joto will kick it into life again.

I have re-downloaded the Joto app (ios) is anyone else facing these issues?

Hi @dom_a2345 - that seems very strange and also unexpected behaviour. It sounds like it might be network connectivity.

Can I ask if you’re using firewall software or are on a work/office network?

Could also be old firmware - if you go into device center, what version does it say you’re on.

Firmware version 1.3.0
What ports does joto use I can try opening those on the firewall but haven’t had an issue before?
I had issues with the firmware update to 1.3 but it did complete after messing around with it for a couple of hours, unless it has failed and is reporting incorrectly?
Can you manually load a firmware via SSH?

Hi @dom_a2345 - IOT port is 8883 which would be the thing causing messages to not get through. There is also a UDP debugging port of 1234

Other things to double check that might help debugging the issue:

  • is Joto going on and offline in the app?
  • is the light remaining off on top of Joto showing it has a constant connection
  • are you using the original power adapter. or a 60w USB-C PD power adapter

With regards to the firmware - there are various ways to do an OTA update but the easiest is via the app as it shows that everything is in working order. There is the full manual option of updating via the USB port but you would need new security certificates from us in order to complete the process. Out of interest, what was it doing when you had issues? Just reverting to the previous version? It may all be linked, because any errors on first start up would cause the firmware to rollback automatically as a precaution.

I will unblock those ports, but i dont think that is the issue.

Yes the joto goes on and offline in the app
I cant see the light as it is against a wall but will look later
yes i am using the original charger

I dont see a way to force a firmware refresh in the app so may need to do it via usb key.

I was on firmware 1.1 and tried to update through the app and it said updating but nothing was happening. When I looked in the context menu it said ‘timed out’, I tried restarting the app but it just said the same thing so I unplugged the joto and plugged it back in, as that was the only option left to me, restarted the app and then tried again. I had the same issue twice more but eventually it seemed to complete.

At the moment the joto believes it is ‘jotting’ and no amount of restarting the app or joto will seem to fix it, the arm is just stuck midway up the board.

Ok - I think lets see what the light is doing first as this will give us a good indication of whats happening.

If it remains on constant while the Joto is going on and offline then it maybe firmware on the motion processor rather than anything to do with the network firmware side of things.

There appears to be no light on at all on the Joto, and the app has been stuck on downloading jot for the last 12 - 24 hours.

Hi @dom_a2345 - I think anything longer than 5 mins and its safe to say that Jot isn’t going to download. If you unplug and plug in Joto - does the light come on and go off again after its joined the network?

Yes, the Joto, seems to be working fine in terms of connecting and registering with the app and when i can get it to download and draw that works fine. I wonder if the issue is when i tried to update from 1.1 to 1.3 and it got stuck and to restart it.
Is there a way to reset and force a firmware update (or refresh)?

Hi @dom_a2345 - can I ask you to email with your Joto ID number - and then we can check the logs, and maybe ask you to do a test while we monitor it.

The firmware should work or not work - as it has an auto rollback on failure - it’s more likely to be the Jot content or your network connection

Thanks for your time tonight over chat. So pleased it is now all sorted. Not sure what you did to fix it in the end, but thanks for getting me back up and jotting.

Hi @dom_a2345 - no problems. Happy to help. For reference I updated the security certificates and it resolved the intermittent connection problem.